Appendix Associated Software

Here is how to obtain the software packages mentioned above.

Apache Webserver

To run any version of Greenstone apart from the Windows Local Library version, you need an external webserver. Many installations, particularly larger ones, will already have a webserver. If you are using Linux, Apache may be on your installation disk but may not have been selected during the installation procedure. The Apache Webserver from www.apache.org is free, and easy to install.

Perl

Greenstone uses the Perl language when building collections. For Windows, Perl is already included in the Greenstone software. Most Unix systems already have Perl installed, but if not, source code and binaries for a wide range of Unix platforms are freely available at www.perl.com . Perl version 5.0 or higher is needed.

GCC

The Unix version of Greenstone compiles under the Gnu C++ compiler, GCC. Greenstone makes extensive use of the C++ standard template library (we've found it to be broken on some older versions of GCC; please tell us if you have STL problems). Note that this version of Greenstone does not compile under GCC 3.0.

GDBM

All versions of Greenstone use the Gnu Database Manager, GDBM. It is supplied with all Windows versions of Greenstone and installed automatically during the installation procedure. Linux systems already have GDBM, so we do not provide it for Linux. Most other Unix systems have it, but if necessary you can download it from www.gnu.org .

Java runtime environment

To use the Greenstone Librarian Interface, you need a suitable version of the Java Runtime Environment. If you don't already have this, a suitable version is included on the CD-ROM, or you can download the latest version from http://java.sun.com/j2se/downloads.html . Version 1.4.0 or higher is needed.

Java compiler

To compile the source code of the Greenstone Librarian Interface, you must first install a Java Development Kit. You can download the J2SE Software Development Kit from http://java.sun.com/j2se/downloads.html . Version 1.4.0 or higher is needed.